The most expensive cable channels

From the Wall Street Journal blog:
OG-AC140_TopTV__G_20140729144610

 

Didn’t watch any of those channels even when I had cable.  So it’s doubly annoying to have been required to subsidize those that did.

I still don’t have a TV and have no plans to get one.  I did build a Plex server (free) which allows one to stream local or web-based video to various devices.  I watch a couple of shows (Longmire, Hannibal, Daily Show)  on my phone/tablet while walking on the treadmill.  Every once in a while if I’m worn out I’ll stream the Plex stuff to the projector, but most of the time I prefer to be doing something at the same time.  TV is such a time suck.

Advertisements

Etekcity usb wifi disconnects

Last year I bought an insanely cheap (~$8) usb-based wifi adapter on sale at Microcenter Like a flashdrive only it’s got wifi innards rather than storage. It sat in a pill bottle because I didn’t actually need it at the time.  It’s very small, sticking out only about 1/4″.

Flash forward to now.  I am repurposing my old MythTV (multimedia) server into a general server here in the house:

  • Minecraft server.  My nephew loves minecraft and having a server means we can play in the same sandbox, together or separately.  Great game, great coder, great company.  To give you an idea how much it is loved, they have sold 16.2 million of the PC version at at $20/ea.
  • icecast server.  This is how I plan to put the Rains County scanner feed online. I’ve done it before in the Dallas area but I have to dig in to remember how it all fits together.
  • maybe a Plex server.  This is also a multimedia server but has a different focus.  MythTV was designed to DVR cable and OTA tv signals.  Plex is more for web-based content and files on your own hard drive.  The server is currently running on my workstation which works fine;  by definition when I am using Plex I am away from my workstation.  So the load on the workstation is not bothersome.

The problem

I formatted the drives on the old MythTV box and installed Lubuntu.  Working great.  But all my machines in the house now are wifi rather than LAN.  I dug out the old Etekcity usb adapter and popped it into the lubuntu server.  Ran nice and fast until it didn’t.

Disconnect.  Manually testart network.  Disconnect again every 5mins;  rinse and repeat.   Arggggh!

Troubleshooting

I ran the lsusb (“list usb devices”) command on the linux shell and this is the line that concerns us:
Bus 001 Device 004: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter

Pro tip:  the “0bda:8176” part identifies the manufacturer:deviceID and the “RTL8188CUS” is the chipset the product is built around.  The chipset information is usually the more useful part.  Google on the chipset and the problem you’re having and learn the state of the issue, fixes, workarounds, whatever.   The solution will generally be the same for any product built around the same chipset.

After a few days of troubleshooting and reading I stumbled across a line in a bug report that indicated the user would have to turn off 802.11n to make the device stable.  This means it would fall back to 802.11b/g.

Solution

Logged into the Verizon provider dsl modem + wifi router and set it for b/g only.  Boom!  Immediate success.  The server has been solidly online ever since.